about summary refs log tree commit diff
path: root/users/wpcarro/scratch/compiler/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2022-10-10T22·25-0700
committerclbot <clbot@tvl.fyi>2022-10-10T22·35+0000
commit0b04dfe03ca380bd234d90efa4f98d76732305f2 (patch)
tree7d50b6f922c5d04fb38a23fc046097a9220c7f31 /users/wpcarro/scratch/compiler/shell.nix
parent019ea51e5c7777d49fa835260b7ce62d77430b3b (diff)
feat(wpcarro/scratch): Rewrite Python compiler in OCaml r/5093
Just to see how productive I could be in OCaml with little familiarity. Overall
I really like it.

Change-Id: I8affc65a5ee86a29d4f8c01426529ae9948660f9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6934
Reviewed-by: wpcarro <wpcarro@gmail.com>
Autosubmit: wpcarro <wpcarro@gmail.com>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--users/wpcarro/scratch/compiler/shell.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/users/wpcarro/scratch/compiler/shell.nix b/users/wpcarro/scratch/compiler/shell.nix
new file mode 100644
index 0000000000..ec339eb91d
--- /dev/null
+++ b/users/wpcarro/scratch/compiler/shell.nix
@@ -0,0 +1,9 @@
+{ pkgs, ... }:
+
+pkgs.mkShell {
+  buildInputs = with pkgs; [
+    ocaml
+    ocamlPackages.utop
+    ocamlformat
+  ];
+}