about summary refs log tree commit diff
path: root/users/wpcarro/nixos/tarasco/hardware.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2022-05-23T03·19-0700
committerclbot <clbot@tvl.fyi>2022-05-27T23·21+0000
commit11a8eea0e392114f5077658b629db30a4eea8b8d (patch)
tree20dbc27ed0d123c18834b24d417b218bf8c58b79 /users/wpcarro/nixos/tarasco/hardware.nix
parente3530149c5939f16ffbc35588d62b84506079c24 (diff)
feat(wpcarro/tarasco): Support tarasco 🇲🇽 r/4154
Named after the Mexican restaurant, El Tarasco, in El Porto, which I live 3m
walking distance from.

Change-Id: I2cd4b68eaa974ad6c8fec73e0566bc0b831c57a8
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5743
Reviewed-by: wpcarro <wpcarro@gmail.com>
Reviewed-by: tazjin <tazjin@tvl.su>
Autosubmit: wpcarro <wpcarro@gmail.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/wpcarro/nixos/tarasco/hardware.nix')
-rw-r--r--users/wpcarro/nixos/tarasco/hardware.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/users/wpcarro/nixos/tarasco/hardware.nix b/users/wpcarro/nixos/tarasco/hardware.nix
new file mode 100644
index 0000000000..2c4da1a3b9
--- /dev/null
+++ b/users/wpcarro/nixos/tarasco/hardware.nix
@@ -0,0 +1,29 @@
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+  imports =
+    [
+      (modulesPath + "/installer/scan/not-detected.nix")
+    ];
+
+  boot.initrd.availableKernelModules = [ "xhci_pci" "ehci_pci" "ahci" "usb_storage" "usbhid" "sd_mod" ];
+  boot.initrd.kernelModules = [ ];
+  boot.kernelModules = [ "kvm-intel" ];
+  boot.extraModulePackages = [ ];
+
+  fileSystems."/" = {
+    device = "/dev/disk/by-label/NIXROOT";
+    fsType = "ext4";
+  };
+
+  fileSystems."/boot" = {
+    device = "/dev/disk/by-label/NIXBOOT";
+    fsType = "vfat";
+  };
+
+  swapDevices = [ ];
+
+  hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+  # high-resolution display
+  hardware.video.hidpi.enable = lib.mkDefault true;
+}