about summary refs log tree commit diff
path: root/users/wpcarro/nixos/marcus/hardware.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2022-05-23T03·17-0700
committerclbot <clbot@tvl.fyi>2022-05-27T22·41+0000
commite3530149c5939f16ffbc35588d62b84506079c24 (patch)
tree7dba3c41575d723d3c024df6be8d2ce3639b2ee2 /users/wpcarro/nixos/marcus/hardware.nix
parent534d7c34fccefbcedbf1d78f6d7e1f8677e326e8 (diff)
refactor(wpcarro/ava): Prefer disk/by-label to disk/by-uuid r/4153
I broke LVM (Logical Volume Manager - maybe?) when I did the following:

```shell
$ HOSTNAME=ava sudo rebuild-system
$ sudo reboot now
```

I had to rollback to the initial NixOS version and try again.

Change-Id: If90e5e23767392202425181be986f81deb5ddff7
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5742
Reviewed-by: wpcarro <wpcarro@gmail.com>
Autosubmit: wpcarro <wpcarro@gmail.com>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--users/wpcarro/nixos/marcus/hardware.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/users/wpcarro/nixos/marcus/hardware.nix b/users/wpcarro/nixos/marcus/hardware.nix
index cd80685abe..329926269a 100644
--- a/users/wpcarro/nixos/marcus/hardware.nix
+++ b/users/wpcarro/nixos/marcus/hardware.nix
@@ -11,12 +11,12 @@
   boot.extraModulePackages = [ ];
 
   fileSystems."/" = {
-    device = "/dev/disk/by-uuid/b8b911ee-e9b9-40ea-89d6-551f11350e7b";
+    device = "/dev/disk/by-label/NIXROOT";
     fsType = "ext4";
   };
 
   fileSystems."/boot" = {
-    device = "/dev/disk/by-uuid/A7EA-369C";
+    device = "/dev/disk/by-label/NIXBOOT";
     fsType = "vfat";
   };