about summary refs log tree commit diff
path: root/users/wpcarro/nixos/marcus/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2021-12-23T21·38-0500
committerclbot <clbot@tvl.fyi>2021-12-23T21·41+0000
commit9b2163cb32b599bd34253042faa43db7fd87cdb9 (patch)
treed3ea35ea6e08f3035c6776400905470ddce91c9d /users/wpcarro/nixos/marcus/default.nix
parent75cbe36dd7c5e77c58b470b2e5d0baaae3caf856 (diff)
feat(wpcarro/marcus): Configure ssh-agent r/3338
- start ssh-agent
- automatically call `ssh-add` after prompting for a password

Change-Id: Ie4319b18923a1439033ee1bae112889fce0930d6
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4544
Reviewed-by: wpcarro <wpcarro@gmail.com>
Autosubmit: wpcarro <wpcarro@gmail.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/wpcarro/nixos/marcus/default.nix')
-rw-r--r--users/wpcarro/nixos/marcus/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/users/wpcarro/nixos/marcus/default.nix b/users/wpcarro/nixos/marcus/default.nix
index 728065a5f9..53132c2d1e 100644
--- a/users/wpcarro/nixos/marcus/default.nix
+++ b/users/wpcarro/nixos/marcus/default.nix
@@ -99,6 +99,12 @@ in {
   programs = {
     fish.enable = true;
     light.enable = true;
+    ssh = {
+      startAgent = true;
+      extraConfig = ''
+        AddKeysToAgent yes
+      '';
+    };
   };
 
   environment.variables = {