about summary refs log tree commit diff
path: root/users/wpcarro/nixos/marcus/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@tvl.su>2024-08-31T22·03+0300
committerclbot <clbot@tvl.fyi>2024-09-05T20·56+0000
commit609b68031b0c0873bdba580c5d743b5557ca79c3 (patch)
tree11405f3a70972a5f5b27837455197ec7afb86e6f /users/wpcarro/nixos/marcus/default.nix
parent200d49a0e1ee19b66f22347888b15ed63da60bcb (diff)
chore(3p/sources): bump channels & overlays (2024-09-01) r/8653
Included changes:

* users/aspen: explicitly use open-source nvidia driver

  This now has to be specified explicitly, otherwise evaluation fails with an
  error.
* users/aspen: nixfmt -> nixfmt-classic
* users/aspen: fixes for renamed packages & options
* users/tazjin: fixes for renamed packages & options
* 3p/overlays: remove cbtemulator patch (merged upstream)
* tvix/shell: remove unnecessary patches (merged upstream)
* 3p/rust-crates: mark libgit2_sys as broken
* users/Profpatsch: mark git-db as broken
* 3p/overlays: pick `mypaint` from stable channel
* tvix: fix comments that clippy doesn't like anymore
* tvix/glue: disable a misfiring clippy lint (applying its suggestion breaks
  code below)

Change-Id: I6d3fc027694bbe7425a2d25dc53d65467a44f3b0
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12403
Tested-by: BuildkiteCI
Reviewed-by: aspen <root@gws.fyi>
Reviewed-by: Profpatsch <mail@profpatsch.de>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'users/wpcarro/nixos/marcus/default.nix')
-rw-r--r--users/wpcarro/nixos/marcus/default.nix11
1 files changed, 6 insertions, 5 deletions
diff --git a/users/wpcarro/nixos/marcus/default.nix b/users/wpcarro/nixos/marcus/default.nix
index 22bc1ca5e2ce..b9ad5f8ed0a4 100644
--- a/users/wpcarro/nixos/marcus/default.nix
+++ b/users/wpcarro/nixos/marcus/default.nix
@@ -50,13 +50,14 @@ in
       interval = "1d";
     };
 
+    libinput = {
+      enable = true;
+      touchpad.naturalScrolling = false;
+      touchpad.tapping = false;
+    };
+
     xserver = {
       enable = true;
-      libinput = {
-        enable = true;
-        touchpad.naturalScrolling = false;
-        touchpad.tapping = false;
-      };
       xkb.layout = "us";
       xkb.options = "caps:escape";
       displayManager = {