about summary refs log tree commit diff
path: root/users/wpcarro/nixos/diogenes/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2021-12-26T00·57-0400
committerclbot <clbot@tvl.fyi>2021-12-26T01·04+0000
commit1d10adb67ccf87cc7461be71905b1ee2378b7c73 (patch)
tree58352aaa91705c8e6d06d58f18352ef4707f1eee /users/wpcarro/nixos/diogenes/default.nix
parent19fbaba04737464f7d8240ee3c38023c7c6774ab (diff)
fix(wpcarro/diogenes): Admit traffic to wpcarro.dev:6698 r/3413
It's difficult to know whether or not I need this. When I run the following
commands...

```
wpcarro@diogenes> nmap localhost
PORT     STATE  SERVICE
22/tcp  open  ssh
80/tcp  open  http
443/tcp open  https

wpcarro@diogenes> nmap wpcarro.dev
PORT     STATE  SERVICE
22/tcp   open   ssh
80/tcp   open   http
443/tcp  open   https
3389/tcp closed ms-wbt-server
```

...neither localhost nor wpcarro.dev reports 6698 being open even though 6698 is
configured to be open in both:
- diogenes/default.nix
- GCP console

Right now, quasselcore is WAI, so I don't want to invest more time into closing
this loop.

Change-Id: I3d68fd901314aa7d364abf9381dff101411e6d15
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4629
Reviewed-by: wpcarro <wpcarro@gmail.com>
Autosubmit: wpcarro <wpcarro@gmail.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/wpcarro/nixos/diogenes/default.nix')
-rw-r--r--users/wpcarro/nixos/diogenes/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/users/wpcarro/nixos/diogenes/default.nix b/users/wpcarro/nixos/diogenes/default.nix
index 4004857c59..af49f33aa1 100644
--- a/users/wpcarro/nixos/diogenes/default.nix
+++ b/users/wpcarro/nixos/diogenes/default.nix
@@ -11,7 +11,11 @@ in {
 
   networking = {
     hostName = "diogenes";
-    firewall.allowedTCPPorts = [ 80 443 ];
+    firewall.allowedTCPPorts = [
+      80   # http
+      443  # https
+      6698 # quassel
+    ];
   };
 
   # Use the TVL binary cache