about summary refs log tree commit diff
path: root/users/wpcarro/nixos/diogenes/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2021-12-16T23·29+0000
committerclbot <clbot@tvl.fyi>2021-12-17T22·12+0000
commit06a20ba3df2cb22695868043ded4d0b04ab54e44 (patch)
tree02ea168ee10ff4eafbe1552edb8d58160c1519b6 /users/wpcarro/nixos/diogenes/default.nix
parentcecc249c961735c9a9bd0c8d60e5fec7e4ac3b70 (diff)
fix(ops/diogenes): Ensure diogenes builds r/3288
diogenes "passed" CI because the file was named configuration.nix
(vestage from the NixOS default /etc/nixos/configuration). This CL fixes
some issues I encountered after running depot/bin/rebuild-system.

TL;DR:
- rename configuration.nix -> default.nix to trigger CI
- add diogenes to my systems
- add public SSH key

Change-Id: I24197b8936c201267db6f71f00099dce590eac1d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4388
Tested-by: BuildkiteCI
Reviewed-by: wpcarro <wpcarro@gmail.com>
Reviewed-by: tazjin <mail@tazj.in>
Autosubmit: wpcarro <wpcarro@gmail.com>
Diffstat (limited to 'users/wpcarro/nixos/diogenes/default.nix')
-rw-r--r--users/wpcarro/nixos/diogenes/default.nix58
1 files changed, 58 insertions, 0 deletions
diff --git a/users/wpcarro/nixos/diogenes/default.nix b/users/wpcarro/nixos/diogenes/default.nix
new file mode 100644
index 0000000000..076261eb50
--- /dev/null
+++ b/users/wpcarro/nixos/diogenes/default.nix
@@ -0,0 +1,58 @@
+{ depot, pkgs, ... }:
+{ ... }:
+
+let
+  inherit (depot.users.wpcarro) keys;
+in {
+  imports = [
+    (pkgs.path + "/nixos/modules/virtualisation/google-compute-image.nix")
+  ];
+
+  networking.hostName = "diogenes";
+
+  # Use the TVL binary cache
+  tvl.cache.enable = true;
+
+  # Use 100G volume for /nix
+  fileSystems."/nix" = {
+    device = "/dev/disk/by-uuid/62396bde-9002-4025-83eb-2a6c731b7adc";
+    fsType = "ext4";
+  };
+
+  users = {
+    mutableUsers = true;
+    users = {
+      wpcarro = {
+        isNormalUser = true;
+        extraGroups = [ "wheel" ];
+        openssh.authorizedKeys.keys = keys.all;
+        shell = pkgs.fish;
+      };
+    };
+  };
+
+
+  security.sudo.wheelNeedsPassword = false;
+
+  environment.systemPackages = with pkgs; [
+    fd
+    fzf
+    mkpasswd
+    ripgrep
+    tldr
+    tree
+    vim
+  ];
+
+  services = {
+    depot.automatic-gc = {
+      enable = true;
+      interval = "1 hour";
+      diskThreshold = 16; # GiB
+      maxFreed = 10; # GiB
+      preserveGenerations = "14d";
+    };
+  };
+
+  system.stateVersion = "21.11";
+}