about summary refs log tree commit diff
path: root/users/wpcarro/nixos/diogenes/configuration.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2021-12-16T23·29+0000
committerclbot <clbot@tvl.fyi>2021-12-17T22·12+0000
commit06a20ba3df2cb22695868043ded4d0b04ab54e44 (patch)
tree02ea168ee10ff4eafbe1552edb8d58160c1519b6 /users/wpcarro/nixos/diogenes/configuration.nix
parentcecc249c961735c9a9bd0c8d60e5fec7e4ac3b70 (diff)
fix(ops/diogenes): Ensure diogenes builds r/3288
diogenes "passed" CI because the file was named configuration.nix
(vestage from the NixOS default /etc/nixos/configuration). This CL fixes
some issues I encountered after running depot/bin/rebuild-system.

TL;DR:
- rename configuration.nix -> default.nix to trigger CI
- add diogenes to my systems
- add public SSH key

Change-Id: I24197b8936c201267db6f71f00099dce590eac1d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4388
Tested-by: BuildkiteCI
Reviewed-by: wpcarro <wpcarro@gmail.com>
Reviewed-by: tazjin <mail@tazj.in>
Autosubmit: wpcarro <wpcarro@gmail.com>
Diffstat (limited to 'users/wpcarro/nixos/diogenes/configuration.nix')
-rw-r--r--users/wpcarro/nixos/diogenes/configuration.nix56
1 files changed, 0 insertions, 56 deletions
diff --git a/users/wpcarro/nixos/diogenes/configuration.nix b/users/wpcarro/nixos/diogenes/configuration.nix
deleted file mode 100644
index afdefce58855..000000000000
--- a/users/wpcarro/nixos/diogenes/configuration.nix
+++ /dev/null
@@ -1,56 +0,0 @@
-{ depot, pkgs, ... }:
-
-let
-  inherit (depot.users.wpcarro) keys;
-in {
-  imports = [
-    "${depot.path}/ops/modules/tvl.nix"
-    "${pkgs.path}/nixos/modules/virtualisation/google-compute-image.nix"
-  ];
-
-  # Use the TVL binary cache
-  tvl.cache.enable = true;
-
-  # Use 100G volume for /nix
-  fileSystems."/nix" = {
-    device = "/dev/disk/by-uuid/5a65f6c2-7d55-414d-b693-1928480c9b96";
-    fsType = "ext4";
-  };
-
-  users = {
-    mutableUsers = true;
-    users = {
-      wpcarro = {
-        isNormalUser = true;
-        extraGroups = [ "wheel" ];
-        openssh.authorizedKeys.keys = keys.all;
-        shell = pkgs.fish;
-      };
-    };
-  };
-
-
-  security.sudo.wheelNeedsPassword = false;
-
-  environment.systemPackages = with pkgs; [
-    fd
-    fzf
-    mkpasswd
-    ripgrep
-    tldr
-    tree
-    vim
-  ];
-
-  services = {
-    depot.automatic-gc = {
-      enable = true;
-      interval = "1 hour";
-      diskThreshold = 16; # GiB
-      maxFreed = 10; # GiB
-      preserveGenerations = "14d";
-    };
-  };
-
-  system.stateVersion = "21.11";
-}