about summary refs log tree commit diff
path: root/users/wpcarro/emacs/pkgs/bookmark/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2022-11-25T05·50-0800
committerwpcarro <wpcarro@gmail.com>2022-11-25T06·27+0000
commit5a0ed0f67ee91f321c5dcdd739f5069bd3634b46 (patch)
tree3a56aa0ba74f9f53060d3053e4df887ee9a12c2d /users/wpcarro/emacs/pkgs/bookmark/default.nix
parent325a7d6fa98ae7dbeabf1d8c1c34c2aed15074dd (diff)
feat(wpcarro/emacs): Package bookmark.el r/5311
More Elisp packaging :)

Change-Id: Ia4971de0815d12f8da1eaa911fa17b8b4896415d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7383
Reviewed-by: wpcarro <wpcarro@gmail.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/wpcarro/emacs/pkgs/bookmark/default.nix')
-rw-r--r--users/wpcarro/emacs/pkgs/bookmark/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/users/wpcarro/emacs/pkgs/bookmark/default.nix b/users/wpcarro/emacs/pkgs/bookmark/default.nix
new file mode 100644
index 0000000000..882481701f
--- /dev/null
+++ b/users/wpcarro/emacs/pkgs/bookmark/default.nix
@@ -0,0 +1,13 @@
+{ pkgs, depot, ... }:
+
+pkgs.callPackage
+  ({ emacsPackages }:
+  emacsPackages.trivialBuild {
+    pname = "bookmark";
+    version = "1.0.0";
+    src = ./bookmark.el;
+    packageRequires = (with pkgs.emacsPackages; [
+      general
+    ]);
+  })
+{ }