about summary refs log tree commit diff
path: root/users/wpcarro/emacs/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2022-08-08T17·53-0700
committerclbot <clbot@tvl.fyi>2022-08-08T17·56+0000
commitb92ceccfdb9d1ba6172e53008e1b5afea32ca20d (patch)
treed4afa3d81cab1546b849e47cbbc5d79b5a271943 /users/wpcarro/emacs/default.nix
parent60f6f5f10e29a67092a6d71e08f92d4631d02617 (diff)
fix(wpcarro/emacs): Update rust configuration r/4393
- Prefer LSP to racer
- Move KBDs to central location

Change-Id: Ib3fbf1b383d711f3ac6dd6d7791374b014b9df90
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6054
Reviewed-by: wpcarro <wpcarro@gmail.com>
Autosubmit: wpcarro <wpcarro@gmail.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/wpcarro/emacs/default.nix')
-rw-r--r--users/wpcarro/emacs/default.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/users/wpcarro/emacs/default.nix b/users/wpcarro/emacs/default.nix
index 203a65d02a..0f14197375 100644
--- a/users/wpcarro/emacs/default.nix
+++ b/users/wpcarro/emacs/default.nix
@@ -11,6 +11,15 @@ let
 
   emacsBinPath = makeBinPath (
     wpcarro.common.shell-utils ++
+    # Rust dependencies
+    (with pkgs; [
+      cargo
+      rls
+      rust-analyzer
+      rustc
+      rustfmt
+    ]) ++
+    # Misc dependencies
     (with pkgs; [
       ispell
       nix
@@ -85,7 +94,6 @@ let
       direnv
       alert
       nix-mode
-      racer
       rust-mode
       rainbow-delimiters
       racket-mode