about summary refs log tree commit diff
path: root/users/wpcarro/emacs/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2021-12-23T23·30-0500
committerwpcarro <wpcarro@gmail.com>2021-12-24T01·46+0000
commitc1e381eeccaa7246ac40e5a58ae5202ead0dfd5f (patch)
tree2de383ed7bd7adaa20face2c09e4857ee48c7515 /users/wpcarro/emacs/default.nix
parent87981e7afd221f76a4361429a043881d6351e657 (diff)
refactor(wpcarro): Remove briefcase references r/3340
TL;DR:
- prefer WPCARRO env-var to BRIEFCASE
- remove repository URLs from Emacs libraries
- prefer tvl-depot-path where possible
- reduce the scope of constants.el
- prune (some not all) stale CI configuration

Change-Id: I21e9130402502ec6fa2fc4b46753c890069be62d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4545
Tested-by: BuildkiteCI
Reviewed-by: wpcarro <wpcarro@gmail.com>
Diffstat (limited to 'users/wpcarro/emacs/default.nix')
-rw-r--r--users/wpcarro/emacs/default.nix13
1 files changed, 5 insertions, 8 deletions
diff --git a/users/wpcarro/emacs/default.nix b/users/wpcarro/emacs/default.nix
index d95f5fa271..f19306c461 100644
--- a/users/wpcarro/emacs/default.nix
+++ b/users/wpcarro/emacs/default.nix
@@ -154,10 +154,9 @@ let
     "${wpcarrosEmacs.deps}/share/emacs/site-lisp:"
   ];
 
-  withEmacsPath = { emacsBin, briefcasePath ? "$HOME/briefcase" }:
+  withEmacsPath = { emacsBin }:
     writeShellScriptBin "wpcarros-emacs" ''
       export XMODIFIERS=emacs
-      export BRIEFCASE=${briefcasePath}
       export GOOGLE_BRIEFCASE="$HOME/google-briefcase"
       export PATH="${emacsBinPath}:$PATH"
       export EMACSLOADPATH="${loadPath}"
@@ -173,9 +172,8 @@ in {
   inherit initEl withEmacsPath;
 
   # I need to start my Emacs from CI without the call to `--load ${initEl}`.
-  runScript = { script, briefcasePath }:
+  runScript = { script }:
     writeShellScript "run-emacs-script" ''
-      export BRIEFCASE=${briefcasePath}
       export PATH="${emacsBinPath}:$PATH"
       export EMACSLOADPATH="${wpcDir}:${vendorDir}:${wpcarrosEmacs.deps}/share/emacs/site-lisp"
       exec ${wpcarrosEmacs}/bin/emacs \
@@ -186,10 +184,9 @@ in {
         "$@"
     '';
 
-  # Use `nix-env -f '<briefcase>' emacs.nixos` to install `wpcarros-emacs` on
-  # NixOS machines.
-  nixos = { briefcasePath ? "$HOME/briefcase" }: withEmacsPath {
-    inherit briefcasePath;
+  nixos = withEmacsPath {
     emacsBin = "${wpcarrosEmacs}/bin/emacs";
   };
+
+  meta.targets = [ "nixos" ];
 }