about summary refs log tree commit diff
path: root/users/wpcarro/emacs/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2022-01-28T06·15-0800
committerclbot <clbot@tvl.fyi>2022-01-28T23·42+0000
commitcdc18c025a519c23fa4dd9e14781349fcdf4035f (patch)
treeb425be89cc1c2fac0ce96eb98de6c13ef657d2c0 /users/wpcarro/emacs/default.nix
parent45da3bce86faec9d21c2e38df325635f5df3d94e (diff)
refactor(wpcarro/emacs): Drop support for vendor directory r/3698
I don't think this is worth lugging around anymore.

Additionally: drop usage of `builtins.path`.

I originally started using `builtins.path` because a blog post about Nix style
recommended it (I cannot remember which), but I'm starting to think this is a
bit too verbose for my taste, and I forget what the benefits are.

Change-Id: If6579f28bac56ad7afec2c5d5a5e4828601c93c3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5083
Reviewed-by: wpcarro <wpcarro@gmail.com>
Autosubmit: wpcarro <wpcarro@gmail.com>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--users/wpcarro/emacs/default.nix26
1 files changed, 2 insertions, 24 deletions
diff --git a/users/wpcarro/emacs/default.nix b/users/wpcarro/emacs/default.nix
index 2986dd7b51..40e6f8d65d 100644
--- a/users/wpcarro/emacs/default.nix
+++ b/users/wpcarro/emacs/default.nix
@@ -119,30 +119,8 @@ let
       emojify
     ]));
 
-  vendorDir = path {
-    path = ./.emacs.d/vendor;
-    name = "emacs-vendor";
-  };
-
-  # TODO(wpcarro): byte-compile these by packaging each as an Elisp library.
-  wpcDir = path {
-    path = ./.emacs.d/wpc;
-    name = "emacs-libs";
-  };
-
-  wpcPackageEl = path {
-    path = ./.emacs.d/wpc/wpc-package.el;
-    name = "wpc-package.el";
-  };
-
-  initEl = path {
-    path = ./.emacs.d/init.el;
-    name = "init.el";
-  };
-
   loadPath = concatStringsSep ":" [
-    wpcDir
-    vendorDir
+    ./.emacs.d/wpc
     # TODO(wpcarro): Explain why the trailing ":" is needed.
     "${wpcarrosEmacs.deps}/share/emacs/site-lisp:"
   ];
@@ -162,7 +140,7 @@ let
         --no-init-file \
         --no-site-file \
         --no-site-lisp \
-        --load ${initEl} \
+        --load ${./.emacs.d/init.el} \
         "$@"
     '';
 in {