about summary refs log tree commit diff
path: root/users/wpcarro/common.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2021-12-25T02·12-0500
committerwpcarro <wpcarro@gmail.com>2021-12-25T16·07+0000
commitd21bc0afc3eb5bd84c0d576370ccc8a94018f0ab (patch)
tree0a43d08ad53dc896705d6b4a79f7f3104722da15 /users/wpcarro/common.nix
parent4eb0dea713bec8aa79dd7dc5540e5daafd301cf9 (diff)
refactor(wpcarro/nixos): Define common.programs mixin r/3395
DRYing-up more configuration.

Change-Id: I390cedd6a325ac17ef06c0887d3e0ac2b387b85b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4601
Reviewed-by: wpcarro <wpcarro@gmail.com>
Autosubmit: wpcarro <wpcarro@gmail.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/wpcarro/common.nix')
-rw-r--r--users/wpcarro/common.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/users/wpcarro/common.nix b/users/wpcarro/common.nix
index 7093b5f1d4..b8ecc6843c 100644
--- a/users/wpcarro/common.nix
+++ b/users/wpcarro/common.nix
@@ -1,6 +1,25 @@
 { pkgs, ... }:
 
 {
+  programs = {
+    fish.enable = true;
+
+    ssh = {
+      startAgent = true;
+      extraConfig = ''
+        AddKeysToAgent yes
+      '';
+    };
+
+    git = {
+      enable = true;
+      config = {
+        user.name = "William Carroll";
+        user.email = "wpcarro@gmail.com";
+      };
+    };
+  };
+
   services = {
     depot.automatic-gc = {
       enable = true;