about summary refs log tree commit diff
path: root/users/wpcarro/common.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2021-12-24T23·44-0500
committerclbot <clbot@tvl.fyi>2021-12-24T23·56+0000
commitc154e6689de542afa2d23f0b6a95288db8ee39a2 (patch)
tree5dbc9cd5b6c4f350a1334f2be2824fd4820370ab /users/wpcarro/common.nix
parent9e557842651f137c0e2c2bfe9fc41d768a492331 (diff)
refactor(wpcarro): Define common.shell-utils r/3380
DRYing up some of my configuration.

Change-Id: I137692789426efc6a6c6880029e605813674fdbe
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4592
Reviewed-by: wpcarro <wpcarro@gmail.com>
Autosubmit: wpcarro <wpcarro@gmail.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/wpcarro/common.nix')
-rw-r--r--users/wpcarro/common.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/users/wpcarro/common.nix b/users/wpcarro/common.nix
new file mode 100644
index 0000000000..79e2eecf5a
--- /dev/null
+++ b/users/wpcarro/common.nix
@@ -0,0 +1,27 @@
+{ pkgs, ... }:
+
+{
+  # Command-line tools I commonly used and want available on most (or all) of my
+  # machines.
+  shell-utils = with pkgs; [
+    bat
+    dig
+    direnv
+    diskus
+    emacs
+    exa
+    fd
+    fzf
+    git
+    jq
+    mkpasswd
+    nmap
+    python3
+    ripgrep
+    tldr
+    tokei
+    tree
+    vim
+    xclip
+  ];
+}