about summary refs log tree commit diff
path: root/users/wpcarro/common.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2021-12-25T02·11-0500
committerwpcarro <wpcarro@gmail.com>2021-12-25T16·07+0000
commit4eb0dea713bec8aa79dd7dc5540e5daafd301cf9 (patch)
treeaecb713453a2931d893c7bef2e041e4f01ba07f2 /users/wpcarro/common.nix
parent5a943eb2cd4db62632633e7513994aaddb034bc2 (diff)
refactor(wpcarro/nixos): Define common.services r/3394
DRY things up with this mixin.

Change-Id: I5791a50b01902734dff91d391e1aa90a21ce4fbb
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4600
Reviewed-by: wpcarro <wpcarro@gmail.com>
Autosubmit: wpcarro <wpcarro@gmail.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/wpcarro/common.nix')
-rw-r--r--users/wpcarro/common.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/users/wpcarro/common.nix b/users/wpcarro/common.nix
index 79e2eecf5a..7093b5f1d4 100644
--- a/users/wpcarro/common.nix
+++ b/users/wpcarro/common.nix
@@ -1,6 +1,16 @@
 { pkgs, ... }:
 
 {
+  services = {
+    depot.automatic-gc = {
+      enable = true;
+      interval = "1 hour";
+      diskThreshold = 16; # GiB
+      maxFreed = 10; # GiB
+      preserveGenerations = "14d";
+    };
+  };
+
   # Command-line tools I commonly used and want available on most (or all) of my
   # machines.
   shell-utils = with pkgs; [