about summary refs log tree commit diff
path: root/users/tazjin/rlox/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-01-17T20·03+0300
committertazjin <mail@tazj.in>2021-01-17T21·17+0000
commit7fb93fb49008491184a7d55ccd43db846452dce0 (patch)
treee07383f72d95ee2cfc150811a99af7caef87bb55 /users/tazjin/rlox/Cargo.toml
parentb1d0e22b1f5fe907ba3d48931e5a38b9a75b0dcf (diff)
feat(tazjin/rlox): Bootstrap VM for Lox bytecode r/2127
Change-Id: I479e20bf2087e5c4aa20e31b364c57ed0d961bcf
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2416
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'users/tazjin/rlox/Cargo.toml')
-rw-r--r--users/tazjin/rlox/Cargo.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/users/tazjin/rlox/Cargo.toml b/users/tazjin/rlox/Cargo.toml
index 1562e7ecc2..b66af6ba85 100644
--- a/users/tazjin/rlox/Cargo.toml
+++ b/users/tazjin/rlox/Cargo.toml
@@ -4,6 +4,7 @@ version = "0.1.0"
 authors = ["Vincent Ambo <mail@tazj.in>"]
 edition = "2018"
 
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
-[dependencies]
+[features]
+# Enables debugging/disassembling in the bytecode interpreter. Off by
+# default as it is quite spammy.
+disassemble = []