about summary refs log tree commit diff
path: root/users/tazjin/presentations/tvix-eval-2023/wasm-fs-demo/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-09-02T10·02+0300
committertazjin <tazjin@tvl.su>2023-09-02T18·20+0000
commit4ef86040ddc4f5f63465776f1dc984163a449bbe (patch)
treed0896cbba707a9b76db2160b66e85977e1983f58 /users/tazjin/presentations/tvix-eval-2023/wasm-fs-demo/Cargo.toml
parent0e01e91174814fee7d1b3685933d5a974a60bc74 (diff)
feat(tazjin/presentations): add (intentionally) broken WASM demo r/6542
This demonstrates a Rust stdlib call that just causes runtime panics
on WASM, for explaining the problems with porting Tvixbolt.

Change-Id: Ief974f1bba509fdac4b9bc9f862ee8f4dfc5158e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9206
Tested-by: BuildkiteCI
Reviewed-by: Mark Shevchenko <markshevchenko@gmail.com>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'users/tazjin/presentations/tvix-eval-2023/wasm-fs-demo/Cargo.toml')
-rw-r--r--users/tazjin/presentations/tvix-eval-2023/wasm-fs-demo/Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/users/tazjin/presentations/tvix-eval-2023/wasm-fs-demo/Cargo.toml b/users/tazjin/presentations/tvix-eval-2023/wasm-fs-demo/Cargo.toml
new file mode 100644
index 000000000000..4a445065e441
--- /dev/null
+++ b/users/tazjin/presentations/tvix-eval-2023/wasm-fs-demo/Cargo.toml
@@ -0,0 +1,7 @@
+[package]
+name = "wasm-fs-demo"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+yew = { version = "0.20.0", features = [ "csr" ]}