about summary refs log tree commit diff
path: root/users/tazjin/predlozhnik/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-07-27T11·04+0300
committertazjin <tazjin@tvl.su>2022-07-27T21·54+0000
commitd795a05c0719dd75b67327cb7cfdaaf6aded16dd (patch)
tree1fdb4464690e39c254034a1b7498c48322067ae3 /users/tazjin/predlozhnik/Cargo.toml
parent38d01f7f3b3f5679e704456fe3ec51c768a7a052 (diff)
feat(tazjin/predlozhnik): bootstrap yew/wasm-based web UI r/4325
this commit is mostly to figure out hwo to build a yew application in
depot using the wasm toolchain. it's a bit finnicky, but could be a
lot worse.

Change-Id: I7804a774f1686a1f308ae1a3f549cd0ae7b5dbeb
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5980
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'users/tazjin/predlozhnik/Cargo.toml')
-rw-r--r--users/tazjin/predlozhnik/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/users/tazjin/predlozhnik/Cargo.toml b/users/tazjin/predlozhnik/Cargo.toml
index 316ed717eb..a47503533b 100644
--- a/users/tazjin/predlozhnik/Cargo.toml
+++ b/users/tazjin/predlozhnik/Cargo.toml
@@ -6,3 +6,7 @@ edition = "2021"
 [dependencies]
 maplit = "1.0"
 lazy_static = "1.4"
+yew = "0.19"
+
+# needs to be in sync with nixpkgs
+wasm-bindgen = "= 0.2.81"