about summary refs log tree commit diff
path: root/users/tazjin/nixos/tverskoy/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-11-02T12·02+0100
committertazjin <mail@tazj.in>2021-11-02T12·18+0000
commite99d8510d7f8d47cbf6217b2b6c7cd64d9457570 (patch)
treecfc18ad09bd41afab648ec8340cc3a2712749187 /users/tazjin/nixos/tverskoy/default.nix
parent18315b2fb60a59a1f4e1b6f91423f34aa580f99a (diff)
feat(tazjin/tverskoy): Add dunst configuration r/2997
This one is basically taken from some gist linked in the official
dunst readme and makes nice little boxes.

Change-Id: I5bee8488f333dcc2f7040b741729065ef8617ae0
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3767
Reviewed-by: tazjin <mail@tazj.in>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--users/tazjin/nixos/tverskoy/default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/users/tazjin/nixos/tverskoy/default.nix b/users/tazjin/nixos/tverskoy/default.nix
index 9f19210d17..dbd20178d8 100644
--- a/users/tazjin/nixos/tverskoy/default.nix
+++ b/users/tazjin/nixos/tverskoy/default.nix
@@ -367,6 +367,15 @@ in lib.fix(self: {
         lockCmd = "${screenLock}/bin/tazjin-screen-lock";
       };
 
+      services.dunst.enable = true;
+
+      xdg.configFile."dunst/dunstrc" = {
+        source = depot.users.tazjin.dotfiles.dunstrc;
+        onChange = ''
+          ${pkgs.procps}/bin/pkill -u "$USER" ''${VERBOSE+-e} dunst || true
+        '';
+      };
+
       systemd.user.startServices = true;
     };