about summary refs log tree commit diff
path: root/users/tazjin/nixos/tverskoy/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-11-27T14·40+0300
committerVincent Ambo <mail@tazj.in>2021-11-27T14·53+0300
commit67d7bc2fa8a6b333a424a62cf9030356923dcaac (patch)
tree599e0679e81ee1417b920205768b07a327134b9b /users/tazjin/nixos/tverskoy/default.nix
parent604319850c4b875fb8cdb9c1e7ca34f013993f20 (diff)
fix(tazjin/tverskoy): Persist Zoxide state between reboots r/3100
Change-Id: Ib1e1fe9749e56eefc83016b1946e6fe0b1f72339
Diffstat (limited to 'users/tazjin/nixos/tverskoy/default.nix')
-rw-r--r--users/tazjin/nixos/tverskoy/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/users/tazjin/nixos/tverskoy/default.nix b/users/tazjin/nixos/tverskoy/default.nix
index b691fce379..9fe3244683 100644
--- a/users/tazjin/nixos/tverskoy/default.nix
+++ b/users/tazjin/nixos/tverskoy/default.nix
@@ -339,6 +339,7 @@ in lib.fix(self: {
           ".local/share/Steam"
           ".local/share/direnv"
           ".local/share/fish"
+          ".local/share/zoxide"
           ".mozilla/firefox"
           ".password-store"
           ".rustup"
@@ -365,6 +366,13 @@ in lib.fix(self: {
         };
       };
 
+      programs.fish = {
+        enable = true;
+        interactiveShellInit = ''
+          ${pkgs.zoxide}/bin/zoxide init fish | source
+        '';
+      };
+
       services.screen-locker = {
         enable = true;
         enableDetectSleep = true;