about summary refs log tree commit diff
path: root/users/tazjin/nixos/tverskoy/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-01-15T16·18+0300
committerclbot <clbot@tvl.fyi>2022-01-17T13·57+0000
commit24b6fe0e101c14419070d87863c24415eeed32b8 (patch)
treeecd52a508b5be7d7b20f1b52ba3f1ad1067921db /users/tazjin/nixos/tverskoy/default.nix
parent1f3aa71cf23d84ad16193d697b21d911db313d17 (diff)
feat(tazjin/tverskoy): Enable & persist gnome-keyring r/3617
Required by Fractal.

Change-Id: Ic82b0d83f6d7c30639c2e149dad79ba4c1a30e88
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4943
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'users/tazjin/nixos/tverskoy/default.nix')
-rw-r--r--users/tazjin/nixos/tverskoy/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/users/tazjin/nixos/tverskoy/default.nix b/users/tazjin/nixos/tverskoy/default.nix
index e011f293f2..67c162f3bd 100644
--- a/users/tazjin/nixos/tverskoy/default.nix
+++ b/users/tazjin/nixos/tverskoy/default.nix
@@ -201,6 +201,9 @@ in lib.fix(self: {
       maxFreed = 10; # GiB
       preserveGenerations = "14d";
     };
+
+    # Run keyring daemon, solely required by Fractal.
+    gnome.gnome-keyring.enable = true;
   };
 
   # Set variables to enable EXWM-XIM
@@ -229,12 +232,12 @@ in lib.fix(self: {
   };
 
   programs = {
+    adb.enable = true;
     fish.enable = true;
     light.enable = true;
-    ssh.startAgent = true;
     mosh.enable = true;
+    ssh.startAgent = true;
     steam.enable = true;
-    adb.enable = true;
 
     # Required by impermanence
     fuse.userAllowOther = true;