about summary refs log tree commit diff
path: root/users/tazjin/nixos/tverskoy/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-14T10·36+0200
committertazjin <mail@tazj.in>2021-04-14T11·20+0000
commitdd42891ab0ae7fbef3b6ed10f065321cef3fdb61 (patch)
treeaf365e87449570afff3d6b27b096f34e222abe5c /users/tazjin/nixos/tverskoy/default.nix
parent8f59300ae815247148b501d99858bce3ec65fe7f (diff)
refactor(tazjin/emacs): Install google-c-style by default r/2507
It is easier to do the inverse of this solution: Filter out the
package on the machines that get it from elsewhere.

Change-Id: I2abe112e4e38822d0fc7a47ea0bcedec1e0a96e3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3010
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to '')
-rw-r--r--users/tazjin/nixos/tverskoy/default.nix12
1 files changed, 3 insertions, 9 deletions
diff --git a/users/tazjin/nixos/tverskoy/default.nix b/users/tazjin/nixos/tverskoy/default.nix
index c2694bf5eb..48bd615049 100644
--- a/users/tazjin/nixos/tverskoy/default.nix
+++ b/users/tazjin/nixos/tverskoy/default.nix
@@ -1,12 +1,6 @@
 { depot, lib, pkgs, ... }:
 
 config: let
-  # add google-c-style here because other machines get it from, eh,
-  # elsewhere.
-  emacs = (depot.users.tazjin.emacs.overrideEmacs(epkgs: epkgs ++ [
-    pkgs.emacsPackages.google-c-style
-  ]));
-
   nixpkgs = import pkgs.path {
     config.allowUnfree = true;
   };
@@ -185,7 +179,7 @@ in lib.fix(self: {
 
       windowManager.session = lib.singleton {
         name = "exwm";
-        start = "${emacs}/bin/tazjins-emacs";
+        start = "${depot.users.tazjin.emacs}/bin/tazjins-emacs";
       };
     };
   };
@@ -220,10 +214,10 @@ in lib.fix(self: {
   environment.systemPackages =
     # programs from the depot
     (with depot; [
-      emacs
+      screenLock
       third_party.lieer
       tools.nsfv-setup
-      screenLock
+      users.tazjin.emacs
     ]) ++
 
     # programs from nixpkgs