about summary refs log tree commit diff
path: root/users/tazjin/nixos/tverskoy/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-03-21T03·27+0200
committertazjin <mail@tazj.in>2021-03-21T13·06+0000
commitdb20dce4f9ceb466bc9eb731952c9bde45d5d248 (patch)
treeae0ece59032969b3f5d15363f3cae0c0d08101f7 /users/tazjin/nixos/tverskoy/default.nix
parent07d99a30e264a00b12adf6e34270abed3c732e7f (diff)
chore(tazjin/tverskoy): Enable SSH agent, Spotify, mullvad, ... r/2307
Just a few more missing things.

Change-Id: I54b633296d91c6f8dce72d900d7d38b8af4ae419
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2625
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to '')
-rw-r--r--users/tazjin/nixos/tverskoy/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/users/tazjin/nixos/tverskoy/default.nix b/users/tazjin/nixos/tverskoy/default.nix
index a7b611c711..977f364996 100644
--- a/users/tazjin/nixos/tverskoy/default.nix
+++ b/users/tazjin/nixos/tverskoy/default.nix
@@ -122,6 +122,7 @@ in lib.fix(self: {
   };
 
   security.rtkit.enable = true;
+
   services = {
     pipewire = {
       enable = true;
@@ -131,6 +132,7 @@ in lib.fix(self: {
 
     redshift.enable = true;
     blueman.enable = true;
+    mullvad-vpn.enable = true;
 
     xserver = {
       enable = true;
@@ -172,7 +174,9 @@ in lib.fix(self: {
   };
 
   programs = {
+    fish.enable = true;
     light.enable = true;
+    ssh.startAgent = true;
 
     # Required by impermanence
     fuse.userAllowOther = true;
@@ -207,6 +211,7 @@ in lib.fix(self: {
       jq
       manpages
       msmtp
+      mullvad-vpn
       networkmanagerapplet
       nix-prefetch-github
       notmuch
@@ -222,6 +227,7 @@ in lib.fix(self: {
       rustup
       screen
       scrot
+      spotify
       tokei
       tree
       vlc