about summary refs log tree commit diff
path: root/users/tazjin/nixos/modules/physical.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-05-09T15·04+0200
committertazjin <tazjin@tvl.su>2022-05-10T13·41+0000
commit5518f620bbec2e4407519a4a5b71073c9ed380af (patch)
treea27204451742773ce8d62c02f09a6c63a794a4b6 /users/tazjin/nixos/modules/physical.nix
parentc4a3500d7024df199572c102420a4c8398344c1a (diff)
refactor(tazjin/nixos): Split up desktop/laptop configurations r/4047
Change-Id: I0f5d631491be0c811ad171510568aac097d2fddd
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5553
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'users/tazjin/nixos/modules/physical.nix')
-rw-r--r--users/tazjin/nixos/modules/physical.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/users/tazjin/nixos/modules/physical.nix b/users/tazjin/nixos/modules/physical.nix
index 4517d9aeb0..ee89284aa8 100644
--- a/users/tazjin/nixos/modules/physical.nix
+++ b/users/tazjin/nixos/modules/physical.nix
@@ -72,4 +72,16 @@
       xsecurelock
       zoxide
     ]);
+
+  # Run services & configure programs for all machines.
+  services = {
+    mullvad-vpn.enable = true;
+    fwupd.enable = true;
+  };
+
+  programs = {
+    fish.enable = true;
+    mosh.enable = true;
+    ssh.startAgent = true;
+  };
 }