about summary refs log tree commit diff
path: root/users/tazjin/homepage/feed.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-06-15T23·18+0300
committerclbot <clbot@tvl.fyi>2023-06-15T23·26+0000
commitd8d0b178234fc6ca2903af00d0c78d5931e27e3f (patch)
tree8120066331508c3d27fdcba5f21a329311ada8f2 /users/tazjin/homepage/feed.nix
parent0b2f5510ed1cf4892fee94de2692bd493ec16fb7 (diff)
refactor(tazjin/homepage): long overdue entry list rework r/6322
The entry list is now much more condensed. It's maybe a little *too*
condensed, but already closer to what I'm looking for.

Note: A new "note" post type has snuck in and can now be used for
random musings or comments on previous entries. Notes do not show up
in the Atom feed.

Change-Id: I920c0c7650937474b8a5f30cba78416554d523ce
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8806
Reviewed-by: tazjin <tazjin@tvl.su>
Autosubmit: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/tazjin/homepage/feed.nix')
-rw-r--r--users/tazjin/homepage/feed.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/users/tazjin/homepage/feed.nix b/users/tazjin/homepage/feed.nix
index 09bc36341401..8043d7ff308a 100644
--- a/users/tazjin/homepage/feed.nix
+++ b/users/tazjin/homepage/feed.nix
@@ -4,7 +4,7 @@
 with depot.nix.yants;
 
 let
-  inherit (builtins) map readFile;
+  inherit (builtins) filter map readFile;
   inherit (lib) max singleton;
   inherit (pkgs) writeText;
   inherit (depot.web) blog atom-feed;
@@ -23,7 +23,7 @@ let
   });
 
   allEntries = (with depot.users.tazjin.blog; map (blog.toFeedEntry config) posts)
-    ++ (map pageEntryToEntry pageEntries);
+    ++ (map pageEntryToEntry (filter (e: e.class != "note") pageEntries));
 
   feed = {
     id = "https://tazj.in/";