about summary refs log tree commit diff
path: root/users/tazjin/home/shared.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@tvl.su>2024-09-07T11·39+0300
committerclbot <clbot@tvl.fyi>2024-09-07T15·58+0000
commit7903d260541ed23e118c598a97d0619b6fb5e42e (patch)
tree454087d4403951cba82f2b6ef5c5a858e4689ea7 /users/tazjin/home/shared.nix
parent863146295b2e644d39379342b357b52355017d7f (diff)
refactor(tazjin/dotfiles): move waybar configuration into Nix r/8664
Change-Id: Ia031fd755ecf451b0ef1f9e63f3aec8b56fe2d57
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12448
Reviewed-by: tazjin <tazjin@tvl.su>
Autosubmit: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/tazjin/home/shared.nix')
-rw-r--r--users/tazjin/home/shared.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/users/tazjin/home/shared.nix b/users/tazjin/home/shared.nix
index 5cbc4b98f068..887668a2f9fd 100644
--- a/users/tazjin/home/shared.nix
+++ b/users/tazjin/home/shared.nix
@@ -74,6 +74,15 @@ in
     };
   };
 
+  programs.waybar = {
+    enable = true;
+    settings = depot.users.tazjin.dotfiles.waybar.config;
+    style = depot.users.tazjin.dotfiles.waybar.style;
+    systemd.enable = true;
+  };
+  systemd.user.services.waybar.Unit.After = lib.mkForce [ "niri.service" ];
+
+
   services.swayidle = let cmd = "${pkgs.swaylock}/bin/swaylock -fFkl -c 008080"; in {
     enable = true;
     events = [