about summary refs log tree commit diff
path: root/users/tazjin/gio-list-apps/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@tvl.su>2023-08-29T12·43+0300
committerclbot <clbot@tvl.fyi>2023-08-29T14·07+0000
commite5f7fe430d582c96b911b79dad03fad7c2d6aa9e (patch)
tree16528afb6d7aabedac82244ef8f3556ed23f13c9 /users/tazjin/gio-list-apps/Cargo.toml
parentd6bce3f83d2c1052c38ecba1445bbc10a9f03123 (diff)
refactor(tazjin/gio-list-apps): refactor into dynamic Emacs module r/6534
Instead of producing a binary that gets called by Emacs, with
input/output serialisation, use a dynamic Emacs module that lets Emacs
more-or-less directly call the relevant GTK functions.

I'm doing this mostly as an experiment. Might be interesting to end up
with a dynamic module that I can dump some experimental code into that
improves my workflows.

To do this, I've exposed the emacs binary used by my Emacs
configuration in an additional `passthru` field. This ensures that the
module is linked against the right version of Emacs.

Change-Id: I1426994fe3455ed1b2a685c5a09705e29fa40950
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9163
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'users/tazjin/gio-list-apps/Cargo.toml')
-rw-r--r--users/tazjin/gio-list-apps/Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/users/tazjin/gio-list-apps/Cargo.toml b/users/tazjin/gio-list-apps/Cargo.toml
index f08260b9880b..eb62d1fcaf42 100644
--- a/users/tazjin/gio-list-apps/Cargo.toml
+++ b/users/tazjin/gio-list-apps/Cargo.toml
@@ -3,8 +3,9 @@ name = "gio-list-apps"
 version = "0.1.0"
 edition = "2021"
 
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[lib]
+crate-type = ["cdylib"]
 
 [dependencies]
+emacs = "0.18.0"
 gio = "0.18.1"
-serde_json = "1.0.105"