about summary refs log tree commit diff
path: root/users/tazjin/emacs/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-08-24T16·40+0300
committertazjin <mail@tazj.in>2021-08-24T17·11+0000
commit42074da8658b672d3ea19ec4abeb9931e5aa2f67 (patch)
tree9ab8fd3acc7d6caa7a7a8231984484fe235a5257 /users/tazjin/emacs/default.nix
parent592aab54b2ed62b2a2d0310c51b3a4d871e53f9d (diff)
refactor(tazjin/emacs): Simplify package selection r/2762
Lets trust that the Emacs overlay is using the right packages from the
right sources by default. I'm not overly attached to any specific
versions.

Change-Id: Id53a4587f680965f13b5cd329a10f0384ff97c13
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3406
Reviewed-by: tazjin <mail@tazj.in>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--users/tazjin/emacs/default.nix58
1 files changed, 22 insertions, 36 deletions
diff --git a/users/tazjin/emacs/default.nix b/users/tazjin/emacs/default.nix
index f094600ebf..e0899fd15b 100644
--- a/users/tazjin/emacs/default.nix
+++ b/users/tazjin/emacs/default.nix
@@ -18,27 +18,16 @@ let
 
   identity = x: x;
 
-  tazjinsEmacs = pkgfun: (emacsWithPackages(epkgs: pkgfun(
-  # Actual ELPA packages (the enlightened!)
-  (with epkgs.elpaPackages; [
-    avy
-    flymake
-    pinentry
-    rainbow-mode
-    undo-tree
-    xelb
-  ]) ++
-
-  # MELPA packages:
-  (with epkgs.melpaPackages; [
-    ace-window
+  tazjinsEmacs = pkgfun: (emacsWithPackages(epkgs: pkgfun(with epkgs; [
     ace-link
-    # bazel-mode TODO(tazjin): where did this go?
+    ace-window
+    avy
+    bazel
     browse-kill-ring
     cargo
-    company
     clojure-mode
     cmake-mode
+    company
     counsel
     counsel-notmuch
     dash-functional
@@ -47,8 +36,11 @@ let
     eglot
     elixir-mode
     elm-mode
-    # erlang
+    erlang
+    exwm
+    flymake
     go-mode
+    google-c-style
     gruber-darker-theme
     haskell-mode
     ht
@@ -69,10 +61,12 @@ let
     notmuch # this comes from pkgs.third_party
     paredit
     password-store
+    pinentry
     polymode
     prescient
     protobuf-mode
     rainbow-delimiters
+    rainbow-mode
     refine
     request
     restclient
@@ -80,37 +74,29 @@ let
     sly
     string-edit
     swiper
+    telega
     telephone-line
     terraform-mode
     toml-mode
     transient
+    undo-tree
     use-package
     uuidgen
+    vterm
     web-mode
     websocket
     which-key
+    xelb
     yaml-mode
     yasnippet
-  ]) ++
-
-  # Other external packages:
-  (with epkgs; [
-    exwm
-    google-c-style
-    telega
-    vterm
-  ]) ++
-
-  # Custom packages
-  (with epkgs.tvlPackages; [
-    dottime
-    nix-util
-    term-switcher
-    tvl
 
-    # patched / overridden versions of packages
-    rcirc
-  ]))));
+    # Custom depot packages (either ours, or overridden ones)
+    tvlPackages.dottime
+    tvlPackages.nix-util
+    tvlPackages.rcirc
+    tvlPackages.term-switcher
+    tvlPackages.tvl
+  ])));
 in lib.fix(self: l: f: pkgs.writeShellScriptBin "tazjins-emacs" ''
   export PATH="${emacsBinPath}:$PATH"
   exec ${tazjinsEmacs f}/bin/emacs \