about summary refs log tree commit diff
path: root/users/tazjin/emacs/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-01-09T13·26+0300
committertazjin <mail@tazj.in>2021-01-13T16·53+0000
commitb4e420d4ff3011b8fd515c2cab33fbde55859b8f (patch)
tree8abd2d9d8368c185c6422d0ba776f6a9d2744e37 /users/tazjin/emacs/default.nix
parent216e7334f6cc8b9a46a8ebc8be4e081f9580c840 (diff)
chore(3p): Bump NixOS channels to 2021-01-09 r/2078
Your regularly scheduled channel update, but slightly more regular
than before.

Included fixes:

* 3p/emacs: Pick telega.el from stable channel, unstable is broken.
* glittershark/fprintd: Compile with gcc9, since build fails with the
  new default of gcc10
* glittershark/fprintd: Use a global overlay for the fprintd package
  until https://github.com/NixOS/nixpkgs/pull/108962 lands in
  nixos-unstable
* glittershark/home: Don't install rr, as it's not building with gcc10

Co-Author: Griffin Smith <grfn@gws.fyi>
Change-Id: Ia715fef64a405a220049fc540017356fa7370e0b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2341
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: glittershark <grfn@gws.fyi>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/tazjin/emacs/default.nix')
-rw-r--r--users/tazjin/emacs/default.nix8
1 files changed, 2 insertions, 6 deletions
diff --git a/users/tazjin/emacs/default.nix b/users/tazjin/emacs/default.nix
index 4e96eff3cf..b1ec90f185 100644
--- a/users/tazjin/emacs/default.nix
+++ b/users/tazjin/emacs/default.nix
@@ -14,12 +14,8 @@ let
 
   emacsWithPackages = (third_party.emacsPackagesGen third_party.emacs27).emacsWithPackages;
 
-  # Pick telega from unstable channel for recent fixes.
-  unstable = import third_party.nixpkgsSrc {};
-  telegaUnstable = (unstable.emacsPackagesGen third_party.emacs27).telega;
-
   # $PATH for binaries that need to be available to Emacs
-  emacsBinPath = lib.makeBinPath [ telegaUnstable ];
+  emacsBinPath = lib.makeBinPath [ third_party.stableTelega ];
 
   identity = x: x;
 
@@ -88,7 +84,6 @@ let
     sly
     string-edit
     swiper
-    telegaUnstable
     telephone-line
     terraform-mode
     toml-mode
@@ -110,6 +105,7 @@ let
     tvl
 
     # patched / overridden versions of packages
+    depot.third_party.stableTelega
     depot.third_party.emacs.exwm
     depot.third_party.emacs.rcirc
     depot.third_party.emacs.vterm