about summary refs log tree commit diff
path: root/users/tazjin/emacs/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-09T22·12+0200
committertazjin <mail@tazj.in>2021-04-10T20·04+0000
commita83abc902456cbdfcf31497c9c788fd9daf66109 (patch)
tree9e19a24f4533186580b446922891c17156beeee7 /users/tazjin/emacs/default.nix
parentd8ec573bc790d3a2b96eaa9ec4185aff8ed31e48 (diff)
chore(tazjin/emacs): Use telega from nixpkgs r/2469
adisbladis fixed the tdlib/telega versioning issues in nixpkgs at some
point, so this isn't required anymore.

Change-Id: Ib98e73d0e4394765f08f5f3741f70adab459c22f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2909
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to '')
-rw-r--r--users/tazjin/emacs/default.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/users/tazjin/emacs/default.nix b/users/tazjin/emacs/default.nix
index 527f0079b2..c7f0f8c03d 100644
--- a/users/tazjin/emacs/default.nix
+++ b/users/tazjin/emacs/default.nix
@@ -7,7 +7,7 @@
 # Forcing Emacs to link against Imagemagick currently causes libvterm
 # to segfault, which is a lot less desirable than not having telega
 # render images correctly.
-{ depot, lib, ... }:
+{ depot, lib, pkgs, ... }:
 
 let
   inherit (depot) third_party;
@@ -15,7 +15,7 @@ let
   emacsWithPackages = (third_party.emacsPackagesGen third_party.emacs27).emacsWithPackages;
 
   # $PATH for binaries that need to be available to Emacs
-  emacsBinPath = lib.makeBinPath [ third_party.telega ];
+  emacsBinPath = lib.makeBinPath [ third_party.emacsPackages.telega ];
 
   identity = x: x;
 
@@ -100,8 +100,10 @@ let
     term-switcher
     tvl
 
+    # telega comes from a mysterious third package set
+    pkgs.emacsPackages.telega
+
     # patched / overridden versions of packages
-    depot.third_party.telega
     depot.third_party.emacs.exwm
     depot.third_party.emacs.rcirc
     depot.third_party.emacs.vterm