about summary refs log tree commit diff
path: root/users/tazjin/dotfiles/waybar/config.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@tvl.su>2024-09-26T21·12+0300
committertazjin <tazjin@tvl.su>2024-09-26T23·27+0000
commited2bd8885052494bcf208f97e292d746f223a117 (patch)
tree2986c5992a6bfe6d9761a8c00c9066772d7b0b4e /users/tazjin/dotfiles/waybar/config.nix
parentd0344a0e278d3b17d07fc96fb9653a3679fc5e63 (diff)
style(tazjin/dotfiles): more authentic win95 waybar styling r/8723
Brings this a LOT closer to the Windows95 style theming that I'm trying to
achieve with the whole thing.

Change-Id: Ifb457a682cb83a78e4a8e2ba2bb4a5b96f3eaf1f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12525
Tested-by: BuildkiteCI
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'users/tazjin/dotfiles/waybar/config.nix')
-rw-r--r--users/tazjin/dotfiles/waybar/config.nix34
1 files changed, 19 insertions, 15 deletions
diff --git a/users/tazjin/dotfiles/waybar/config.nix b/users/tazjin/dotfiles/waybar/config.nix
index e65edabe7d19..aeac4f4c1963 100644
--- a/users/tazjin/dotfiles/waybar/config.nix
+++ b/users/tazjin/dotfiles/waybar/config.nix
@@ -7,36 +7,40 @@ in
   mainBar = {
     layer = "top";
     position = "bottom";
-    modules-left = [ "image#start" "custom/start" ];
-
-    "image#start" = {
-      path = "${depot.third_party.chicago95}/share/icons/Chicago95/panel/24/start-here.png";
-      size = 24;
-      on-click = "xfce4-appfinder --disable-server";
-    };
+    modules-left = [ "custom/start" ];
 
     "custom/start" = {
       format = " Start";
       on-click = "xfce4-appfinder --disable-server";
     };
 
-    modules-right = [ "pulseaudio" "backlight" "battery" "tray" "clock" ];
+    modules-right = [ "tray" "backlight" "battery" "pulseaudio" "clock" ];
 
     pulseaudio = {
       on-click = "pavucontrol";
-      # Font "Awesome" speaker icons can't be made to render, I don't care why, emoji time.
-      format = "{volume}% 🎧";
-      format-muted = "{volume}% ";
+      format = " "; #styling only
+      states = {
+        low = 1;
+        medium = 40;
+        high = 75;
+      };
     };
 
     battery = {
-      format = "{capacity}% {icon}";
-      format-icons = [ "" "" "" "" "" ];
+      format = " "; # styling only
+      interval = 10;
+      states = {
+        full = 100;
+        good = 85;
+        medium = 60;
+        low = 40;
+        warning = 20;
+        critical = 10;
+      };
     };
 
     backlight = {
-      format = "{percent}% {icon}";
-      format-icons = [ "" ];
+      format = "{percent}%"; # styling only
       on-scroll-up = "light -A 1";
       on-scroll-down = "light -U 1";
     };