about summary refs log tree commit diff
path: root/users/tazjin/dotfiles/waybar/config.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@tvl.su>2024-09-07T11·39+0300
committerclbot <clbot@tvl.fyi>2024-09-07T15·58+0000
commit7903d260541ed23e118c598a97d0619b6fb5e42e (patch)
tree454087d4403951cba82f2b6ef5c5a858e4689ea7 /users/tazjin/dotfiles/waybar/config.nix
parent863146295b2e644d39379342b357b52355017d7f (diff)
refactor(tazjin/dotfiles): move waybar configuration into Nix r/8664
Change-Id: Ia031fd755ecf451b0ef1f9e63f3aec8b56fe2d57
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12448
Reviewed-by: tazjin <tazjin@tvl.su>
Autosubmit: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/tazjin/dotfiles/waybar/config.nix')
-rw-r--r--users/tazjin/dotfiles/waybar/config.nix51
1 files changed, 51 insertions, 0 deletions
diff --git a/users/tazjin/dotfiles/waybar/config.nix b/users/tazjin/dotfiles/waybar/config.nix
new file mode 100644
index 000000000000..e65edabe7d19
--- /dev/null
+++ b/users/tazjin/dotfiles/waybar/config.nix
@@ -0,0 +1,51 @@
+{ depot, pkgs, ... }:
+
+let
+  launcher = "${pkgs.xfce4-appfinder}/bin/xfce4-appfinder --disable-server";
+in
+{
+  mainBar = {
+    layer = "top";
+    position = "bottom";
+    modules-left = [ "image#start" "custom/start" ];
+
+    "image#start" = {
+      path = "${depot.third_party.chicago95}/share/icons/Chicago95/panel/24/start-here.png";
+      size = 24;
+      on-click = "xfce4-appfinder --disable-server";
+    };
+
+    "custom/start" = {
+      format = " Start";
+      on-click = "xfce4-appfinder --disable-server";
+    };
+
+    modules-right = [ "pulseaudio" "backlight" "battery" "tray" "clock" ];
+
+    pulseaudio = {
+      on-click = "pavucontrol";
+      # Font "Awesome" speaker icons can't be made to render, I don't care why, emoji time.
+      format = "{volume}% 🎧";
+      format-muted = "{volume}% ";
+    };
+
+    battery = {
+      format = "{capacity}% {icon}";
+      format-icons = [ "" "" "" "" "" ];
+    };
+
+    backlight = {
+      format = "{percent}% {icon}";
+      format-icons = [ "" ];
+      on-scroll-up = "light -A 1";
+      on-scroll-down = "light -U 1";
+    };
+
+    clock.format-alt = "{:%a, %d. %b  %H:%M}";
+
+    tray = {
+      icon-size = 20;
+      spacing = 10;
+    };
+  };
+}