about summary refs log tree commit diff
path: root/users/tazjin/dotfiles/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@tvl.su>2024-09-26T21·12+0300
committertazjin <tazjin@tvl.su>2024-09-26T23·27+0000
commited2bd8885052494bcf208f97e292d746f223a117 (patch)
tree2986c5992a6bfe6d9761a8c00c9066772d7b0b4e /users/tazjin/dotfiles/default.nix
parentd0344a0e278d3b17d07fc96fb9653a3679fc5e63 (diff)
style(tazjin/dotfiles): more authentic win95 waybar styling r/8723
Brings this a LOT closer to the Windows95 style theming that I'm trying to
achieve with the whole thing.

Change-Id: Ifb457a682cb83a78e4a8e2ba2bb4a5b96f3eaf1f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12525
Tested-by: BuildkiteCI
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'users/tazjin/dotfiles/default.nix')
-rw-r--r--users/tazjin/dotfiles/default.nix18
1 files changed, 16 insertions, 2 deletions
diff --git a/users/tazjin/dotfiles/default.nix b/users/tazjin/dotfiles/default.nix
index d536d3a494cd..79c5c2ecad40 100644
--- a/users/tazjin/dotfiles/default.nix
+++ b/users/tazjin/dotfiles/default.nix
@@ -1,8 +1,22 @@
-args: {
+{ depot, pkgs, ... }@args:
+
+rec {
   dunstrc = ./dunstrc;
   niri = ./niri.config.kdl;
   waybar = {
     config = import ./waybar/config.nix args;
-    style = ./waybar/style.css;
+    style = pkgs.runCommandNoCC "waybar-style.css"
+      {
+        CHICAGO95 = depot.third_party.chicago95;
+      } ''
+      cat ${./waybar/style.css} | ${pkgs.envsubst}/bin/envsubst > $out
+    '';
   };
+
+  # Helper derivation for iterating on waybar config.
+  waybarTest = pkgs.runCommandNoCC "waybar-conf" { } ''
+    mkdir -p $out
+    cat ${pkgs.writeText "waybar-conf.json" (builtins.toJSON(builtins.attrValues waybar.config))} > $out/config
+    cp ${waybar.style} $out/style.css
+  '';
 }