about summary refs log tree commit diff
path: root/users/tazjin/aoc2019/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-12-01T12·12+0100
committertazjin <mail@tazj.in>2020-12-01T12·55+0000
commit6c08bcc84d51fd5a1a5152b3c611df44c93a3f00 (patch)
treee630b752c08018aded887c2708e29a30f9ab716d /users/tazjin/aoc2019/default.nix
parent7d7c15c9a69d1d88f66640285ce08eaa3b60078e (diff)
chore(tazjin/aoc2019): Move out of //fun r/1970
Change-Id: I9d065b672f4245b81444737dd900c8864447bc4d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2211
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'users/tazjin/aoc2019/default.nix')
-rw-r--r--users/tazjin/aoc2019/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/users/tazjin/aoc2019/default.nix b/users/tazjin/aoc2019/default.nix
new file mode 100644
index 0000000000..5f1f248c50
--- /dev/null
+++ b/users/tazjin/aoc2019/default.nix
@@ -0,0 +1,22 @@
+# Solutions for Advent of Code 2019, written in Emacs Lisp.
+#
+# For each day a new file is created as "solution-day$n.el".
+{ depot, ... }:
+
+let
+  inherit (builtins) attrNames filter head listToAttrs match readDir;
+  dir = readDir ./.;
+  matchSolution = match "solution-(.*)\.el";
+  isSolution = f: (matchSolution f) != null;
+  getDay = f: head (matchSolution f);
+
+  solutionFiles = filter (e: dir."${e}" == "regular" && isSolution e) (attrNames dir);
+  solutions = map (f: let day = getDay f; in {
+    name = day;
+    value = depot.writeElispBin { # TODO(tazjin): move writeElispBin to depot.nix
+      name = "aoc2019";
+      deps = p: with p; [ dash s ht ];
+      src = ./. + ("/" + f);
+    };
+  }) solutionFiles;
+in listToAttrs solutions