about summary refs log tree commit diff
path: root/users/sterni/modules/disk-checkup.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2023-11-26T11·54+0100
committerclbot <clbot@tvl.fyi>2023-11-26T22·16+0000
commit03d5ffd2ded360341a024dd796a8b27680cfb037 (patch)
tree84348eae3dda4a95eb00ce64e500be80b0962014 /users/sterni/modules/disk-checkup.nix
parent825b6ac65f69737bbcba99058433e0af3fcc33b7 (diff)
feat(sterni/ingeborg): enable btrfs auto scrub r/7070
While we are at it, rename disk-checkup.nix to btrfs-auto-scrub.nix and
move it into //ops/modules. I originally wanted to have additionally
disk health related services in that module, but the btrfs scrub
functionality is nicely self-contained and reusable, so I think it makes
sense to have this in a more central location.

Change-Id: Iabdd62838eef009540ca71abafd921afda2a9b47
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10128
Reviewed-by: sterni <sternenseemann@systemli.org>
Autosubmit: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--users/sterni/modules/disk-checkup.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/users/sterni/modules/disk-checkup.nix b/users/sterni/modules/disk-checkup.nix
deleted file mode 100644
index 8acc08759b..0000000000
--- a/users/sterni/modules/disk-checkup.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-# TODO(sterni): configure smartd and alerts
-{ config, lib, ... }:
-
-{
-  config = {
-    services = {
-      btrfs.autoScrub = {
-        enable = true;
-        interval = "daily";
-        # gather all btrfs fileSystems and overwrite default
-        fileSystems = lib.mkForce (
-          lib.concatLists (
-            lib.mapAttrsToList
-              (
-                _:
-                { fsType, mountPoint, ... }:
-                if fsType == "btrfs" then [ mountPoint ] else [ ]
-              )
-              config.fileSystems
-          )
-        );
-      };
-    };
-  };
-}