about summary refs log tree commit diff
path: root/users/sterni/mblog/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2022-01-31T23·01+0100
committersterni <sternenseemann@systemli.org>2022-02-02T20·47+0000
commit5bc73de59d9f01ec8497ac8ff142506fd7a40876 (patch)
treef5cc93f2c22739091be3f9878c3b8c8cba72d6fd /users/sterni/mblog/default.nix
parent81c47da91c90fd8bac96c6088112f71a11964131 (diff)
feat: move mblog header handling into mime4cl r/3754
Accessing the headers of a MIME message feels like something mime4cl
should handle. We implemented this ad hoc in mblog before in order to
not need to worry about doing it in a sensible way. Now we introduce a
decent-ish interface for getting a header from a MIME message,
mime-message-header-values:

* It returns a list because MIME message headers may appear multiple
  times.

* It decodes RFC2047 only upon request, as you may want to be stricter
  about parsing certain fields.

* It checks header name equality case insensitively.

The code for decoding the RFC2047 string is retained and still uses
babel for doing the actual decoding.

Change-Id: I58bbbe4b46dbded04160b481a28a40d14775673d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5150
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'users/sterni/mblog/default.nix')
-rw-r--r--users/sterni/mblog/default.nix1
1 files changed, 0 insertions, 1 deletions
diff --git a/users/sterni/mblog/default.nix b/users/sterni/mblog/default.nix
index 00e8b39ada0d..607d198930d1 100644
--- a/users/sterni/mblog/default.nix
+++ b/users/sterni/mblog/default.nix
@@ -19,7 +19,6 @@
     }
     depot.lisp.klatre
     depot.third_party.lisp.alexandria
-    depot.third_party.lisp.babel
     depot.third_party.lisp.closure-html
     depot.third_party.lisp.cl-date-time-parser
     depot.third_party.lisp.cl-who