about summary refs log tree commit diff
path: root/users/sterni/machines/edwin/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2022-11-30T14·52+0100
committersterni <sternenseemann@systemli.org>2022-12-01T23·38+0000
commite9df3608e1a6dd580d5825a7cc5972a59f0d464d (patch)
tree1b184bb002279aa848e0e861a77a3ae977880136 /users/sterni/machines/edwin/default.nix
parent1bf1333276a8bd7043738798ca515c9a645f8678 (diff)
feat(sterni/machines/edwin): automatically sync repos with github r/5360
I primarily use GitHub for most of these preexisting repositories,
but they should be properly replicated on edwin in case I want to
stop. Pushing the respective refs manually is cumbersome and error
prone, so let's automate it.

The repositories are basically chowned to git:git currently and
`git fetch <remote> 'refs/*:refs/*' --prune` is execute regularly
to update the repository. In the future I could contemplate doing
it the other way round – using edwin as upstream and using
`git push --mirror` to update the GitHub repositories.

Change-Id: Icb8a11223c0b4d3c8ce9a2da7fb2b4d4df4887f8
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7486
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'users/sterni/machines/edwin/default.nix')
-rw-r--r--users/sterni/machines/edwin/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/users/sterni/machines/edwin/default.nix b/users/sterni/machines/edwin/default.nix
index af1dceada5..de34aa78af 100644
--- a/users/sterni/machines/edwin/default.nix
+++ b/users/sterni/machines/edwin/default.nix
@@ -72,7 +72,7 @@
         root.openssh.authorizedKeys.keys = depot.users.sterni.keys.all;
         lukas = {
           isNormalUser = true;
-          extraGroups = [ "wheel" "http" ];
+          extraGroups = [ "wheel" "http" "git" ];
           openssh.authorizedKeys.keys = depot.users.sterni.keys.all;
           shell = "${pkgs.fish}/bin/fish";
         };