about summary refs log tree commit diff
path: root/users/sterni/clhs-lookup/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-01-29T17·22+0100
committersterni <sternenseemann@systemli.org>2021-01-29T17·36+0000
commit001ee91169c4e25bd3696fc3c69e5151f5547a7f (patch)
tree05e5c5019d1b0df8e119ab49468a32233b2e46a4 /users/sterni/clhs-lookup/default.nix
parent1fb5a17f1430840da4990ffa35a04aca96f06d0a (diff)
feat(users/sterni): move clhs.clhs-lookup to clhs-lookup r/2151
This way ci should pick up on clhs-lookup since only a single derivation
is exposed with the default.nix and it is less cumbersome to type the
attribute path (users.sterni.clhs.clhs-lookup →
users.sterni.clhs-lookup). The exposed CLHS wasn't used for anything
anyways and I can always expose it again using passthru or extra if it's
ever merged.

Change-Id: I6c5aeba1b58ca650700c6efa0913e4b42685ea6b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2461
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'users/sterni/clhs-lookup/default.nix')
-rw-r--r--users/sterni/clhs-lookup/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/users/sterni/clhs-lookup/default.nix b/users/sterni/clhs-lookup/default.nix
new file mode 100644
index 000000000000..951b94d72f19
--- /dev/null
+++ b/users/sterni/clhs-lookup/default.nix
@@ -0,0 +1,36 @@
+{ pkgs, depot, ... }:
+
+let
+  inherit (pkgs) fetchzip writeText;
+  inherit (depot.nix) buildLisp;
+  inherit (builtins) replaceStrings;
+
+  clhsVersion = "7-0";
+
+  clhs = fetchzip {
+    name = "HyperSpec-${replaceStrings [ "-" ] [ "." ] clhsVersion}";
+    url = "ftp://ftp.lispworks.com/pub/software_tools/reference/HyperSpec-${clhsVersion}.tar.gz";
+    sha256 = "1zsi35245m5sfb862ibzy0pzlph48wvlggnqanymhgqkpa1v20ak";
+    stripRoot = false;
+  };
+
+  clhs-path = writeText "clhs-path.lisp" ''
+    (in-package :clhs-lookup.clhs-path)
+    (defparameter *clhs-path* (pathname "${clhs}/"))
+  '';
+
+  clhs-lookup = buildLisp.program {
+    name = "clhs-lookup";
+
+    deps = [
+      (buildLisp.bundled "uiop")
+    ];
+
+    srcs = [
+      ./packages.lisp
+      clhs-path
+      ./clhs-lookup.lisp
+    ];
+  };
+in
+  clhs-lookup