about summary refs log tree commit diff
path: root/users/multi/pkgs/default.nix
diff options
context:
space:
mode:
authormulti <depot@in-addr.xyz>2020-11-22T20·12+0000
committermulti <depot@in-addr.xyz>2020-11-22T20·29+0000
commita5ee01a827e30c048d98fc2121c5c292122d9d3a (patch)
treeb5fc9ac8de0e593eb80de72114eed0522e053136 /users/multi/pkgs/default.nix
parentba9fb4e1123883ffc2410d11146cb63a5aa7841d (diff)
refactor(user/multi/pkgs): make my local package set readTree-compatible. r/1901
This adds readTree configuration for accessing my local package set,
and also adds these packages to the CI configuration.

Change-Id: Icd2d16e85859343902e73a466f3c6ba8d781537f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2131
Tested-by: BuildkiteCI
Reviewed-by: multi <depot@in-addr.xyz>
Diffstat (limited to '')
-rw-r--r--users/multi/pkgs/default.nix15
1 files changed, 11 insertions, 4 deletions
diff --git a/users/multi/pkgs/default.nix b/users/multi/pkgs/default.nix
index e98ed735c4..ee30a10691 100644
--- a/users/multi/pkgs/default.nix
+++ b/users/multi/pkgs/default.nix
@@ -1,6 +1,13 @@
-{ pkgs, ... }:
+{ depot, pkgs, ... }:
 
-let
-  htop = import ./htop { inherit pkgs; };
+let 
+  nixpkgs = import pkgs.nixpkgsSrc {};
+  localpkg = path: import path { pkgs = nixpkgs; };
+
+  packages = {
+    htop = localpkg ./htop;
+  };
 in
-  [ htop ]
+  packages // {
+    meta.targets = builtins.attrNames packages;
+  }