about summary refs log tree commit diff
path: root/users/multi/home/default.nix
diff options
context:
space:
mode:
authormulti <depot@in-addr.xyz>2020-11-22T16·58+0000
committermulti <depot@in-addr.xyz>2020-11-22T19·48+0000
commit69244064da9b60258607fccae4e9c75f0249880f (patch)
treee1bdc7801630278d5009c07cb6ee4b5a69833a22 /users/multi/home/default.nix
parent9d6d945f524c06836c1292b3f9ab862521e32b1a (diff)
refactor(users/multi): make my user directory CI-compatible. r/1898
My home-manager config is not currently readTree compatible, which means
that it's not built by CI. This constructs a house of cards around
home-manager to make this buildable in CI.

Change-Id: I80480f24ff47347f46d708edbbf34d59fa76adac
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2123
Tested-by: BuildkiteCI
Reviewed-by: multi <depot@in-addr.xyz>
Diffstat (limited to 'users/multi/home/default.nix')
-rw-r--r--users/multi/home/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/users/multi/home/default.nix b/users/multi/home/default.nix
new file mode 100644
index 0000000000..b5befe6bb6
--- /dev/null
+++ b/users/multi/home/default.nix
@@ -0,0 +1,27 @@
+{ depot, pkgs, lib, ... }:
+
+let
+  nixpkgs = import pkgs.nixpkgsSrc {};
+  home-modules = import "${nixpkgs.home-manager.src}/modules";
+  outerLib = lib;
+
+  home = path:
+    let 
+      configSet = import path { inherit depot pkgs; };
+    in
+      home-modules {
+        pkgs = nixpkgs;
+        configuration = { config, lib, ... }: (
+          {
+            _module.args.pkgs = outerLib.mkForce (import pkgs.nixpkgsSrc {});
+          } // configSet
+        );
+      };
+
+in
+  rec {
+    whitby = home ./configs/whitby.nix;
+    whitbyHome = whitby.activationPackage;
+
+    meta.targets = [ "whitbyHome" ];
+  }