about summary refs log tree commit diff
path: root/users/grfn/xanthous/shell.nix
diff options
context:
space:
mode:
authorAspen Smith <grfn@gws.fyi>2024-02-12T03·00-0500
committerclbot <clbot@tvl.fyi>2024-02-14T19·37+0000
commit82ecd61f5c699cf3af6c4eadf47a1c52b1d696c6 (patch)
tree429c5e078528000591742ec3211bc768ae913a78 /users/grfn/xanthous/shell.nix
parent0ba476a4266015f278f18d74094299de74a5a111 (diff)
chore(users): grfn -> aspen r/7511
Change-Id: I6c6847fac56f0a9a1a2209792e00a3aec5e672b9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10809
Autosubmit: aspen <root@gws.fyi>
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'users/grfn/xanthous/shell.nix')
-rw-r--r--users/grfn/xanthous/shell.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/users/grfn/xanthous/shell.nix b/users/grfn/xanthous/shell.nix
deleted file mode 100644
index 2c41cb4aa864..000000000000
--- a/users/grfn/xanthous/shell.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-let
-  depot = import ../../../. { };
-  inherit (depot) third_party;
-  pkgs = third_party.nixpkgs;
-in
-
-(pkgs.haskell.packages.ghc8107.extend (pkgs.haskell.lib.packageSourceOverrides {
-  xanthous = third_party.gitignoreSource ./.;
-})).shellFor {
-  packages = p: [ p.xanthous ];
-  withHoogle = true;
-  doBenchmark = true;
-  buildInputs = (with pkgs.haskell.packages.ghc8107; [
-    cabal-install
-    ghc-prof-flamegraph
-    hp2pretty
-    hlint
-    haskell-language-server
-    cabal2nix
-  ]) ++ (with pkgs; [
-    qpdf
-  ]);
-}