about summary refs log tree commit diff
path: root/users/grfn/xanthous/server/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2021-11-07T20·46-0500
committergrfn <grfn@gws.fyi>2021-11-07T21·05+0000
commit77f0d62a2cc87e2a927e2389531b4aa16000139a (patch)
tree06a0d1caadfada2878fdaffc0dc433d874326079 /users/grfn/xanthous/server/default.nix
parentf9f5b0b199167d907a49c5f2975e6b70086796de (diff)
feat(xanthous/server): Add derivation for docker image r/3019
This appears to work pretty nicely!

Change-Id: Icf52f58225ee2837b30ba6187ae3ba3c539de9df
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3810
Reviewed-by: grfn <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/grfn/xanthous/server/default.nix')
-rw-r--r--users/grfn/xanthous/server/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/users/grfn/xanthous/server/default.nix b/users/grfn/xanthous/server/default.nix
index cfb10f642c38..0b3900e4d5fe 100644
--- a/users/grfn/xanthous/server/default.nix
+++ b/users/grfn/xanthous/server/default.nix
@@ -1,4 +1,5 @@
-{ depot ? import ../../../.. {}
+args@{
+  depot ? import ../../../.. {}
 , pkgs ? depot.third_party.nixpkgs
 , ...
 }:
@@ -7,4 +8,7 @@ depot.third_party.naersk.buildPackage {
   name = "xanthous-server";
   version = "0.0.1";
   src = depot.third_party.gitignoreSource ./.;
+  passthru = {
+    docker = import ./docker.nix args;
+  };
 }