about summary refs log tree commit diff
path: root/users/grfn/xanthous/server/Cargo.toml
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2021-11-13T13·54-0500
committergrfn <grfn@gws.fyi>2021-11-13T14·12+0000
commit33f29d081d17c496e2348075b430d8238e2998ea (patch)
tree8c79d70f3665a3ec9678ebda36219857f4846e6f /users/grfn/xanthous/server/Cargo.toml
parent3d4e992c6fc2147e0f0ab9cf3dcc253b777b3a32 (diff)
fix(xanthous/server): Fix decoding secret key r/3056
The actual function we want for the format we're using is
decode_secret_key, not decode_openssh, apparently - covered this with a
toneest to make sure.

Change-Id: I659226169f213b8464b96aec6b94bf13fd80aac8
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3863
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'users/grfn/xanthous/server/Cargo.toml')
-rw-r--r--users/grfn/xanthous/server/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/users/grfn/xanthous/server/Cargo.toml b/users/grfn/xanthous/server/Cargo.toml
index 6772d75ec88f..adb2a02391bd 100644
--- a/users/grfn/xanthous/server/Cargo.toml
+++ b/users/grfn/xanthous/server/Cargo.toml
@@ -24,3 +24,6 @@ base64ct = "<1.2"
 [dependencies.tokio]
 version = "1.13"
 features = ["rt", "rt-multi-thread", "macros", "net", "process", "fs", "signal"]
+
+[dev-dependencies]
+tempfile = "3.2.0"