about summary refs log tree commit diff
path: root/users/grfn/xanthous/server/Cargo.toml
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2021-11-07T21·15-0500
committergrfn <grfn@gws.fyi>2021-11-07T21·18+0000
commit5327d238e3f292e8c5d9b161df1ee3b56665aa96 (patch)
treea440adcf72f863b1046c1707c456d4f62395e8bb /users/grfn/xanthous/server/Cargo.toml
parent77f0d62a2cc87e2a927e2389531b4aa16000139a (diff)
feat(xanthous/server): Add simple prometheus metrics r/3020
Add a prometheus exporter and some simple prometheus metrics, so that I
can look at dashboards and get alerts for things like lots of
connections

Change-Id: Ic1e0568200299dc852b74da647a6354267ee7576
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3811
Reviewed-by: grfn <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/grfn/xanthous/server/Cargo.toml')
-rw-r--r--users/grfn/xanthous/server/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/users/grfn/xanthous/server/Cargo.toml b/users/grfn/xanthous/server/Cargo.toml
index 9299709399..6772d75ec8 100644
--- a/users/grfn/xanthous/server/Cargo.toml
+++ b/users/grfn/xanthous/server/Cargo.toml
@@ -11,6 +11,8 @@ thrussh = "0.33.5"
 thrussh-keys = "0.21.0"
 tracing = "0.1.29"
 tracing-subscriber = "0.2.25"
+metrics = "0.17.0"
+metrics-exporter-prometheus = "0.6.1"
 futures = "0.3.17"
 libc = "0.2.103"
 nix = "0.23.0"