about summary refs log tree commit diff
path: root/users/grfn/xanthous/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2021-11-07T19·24-0500
committergrfn <grfn@gws.fyi>2021-11-07T21·05+0000
commit94be8ad755782faabcbaeef4bd6ae484602a54ee (patch)
tree0b2e777042bd0274e128d67220eccbcbc6265ce2 /users/grfn/xanthous/default.nix
parent9b6497e5da2c29bfc109a62390071c94684e78d5 (diff)
feat(gs/xanthous): Add SSH server application r/3015
Add the start of an ssh-compatible server application for playing
Xanthous over ssh. The idea here is that the user can ssh with whatever
username they like (defaulting obviously to their login username) and
then that gets passed as the --name flag to xanthous as they play.

Change-Id: I39eec288ac8e22a165e859479888d78158a58818
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3806
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'users/grfn/xanthous/default.nix')
-rw-r--r--users/grfn/xanthous/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/users/grfn/xanthous/default.nix b/users/grfn/xanthous/default.nix
index 1316ff583f..90dd5870d7 100644
--- a/users/grfn/xanthous/default.nix
+++ b/users/grfn/xanthous/default.nix
@@ -7,8 +7,10 @@ let
   src = builtins.path {
     name = "xanthous-source";
     path = ./.;
-    filter = path: type: ignore path type
-      || builtins.baseNameOf path == "package.yaml";
+    filter = path: type:
+      !(type == "directory" && builtins.baseNameOf path == "server")
+      && (ignore path type
+          || builtins.baseNameOf path == "package.yaml");
   };
   # generated by cabal2nix
   basePkg = pkgs.haskellPackages.callPackage ./pkg.nix { };