about summary refs log tree commit diff
path: root/users/grfn/terraform/workspace.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2022-09-26T17·33+0200
committersterni <sternenseemann@systemli.org>2022-09-28T08·02+0000
commit0c178a0ef61d2f5f4d6169c7a951663c62509cd7 (patch)
tree08d4b97e5d423f9624211f92700e8bd1cf27fcbc /users/grfn/terraform/workspace.nix
parentf40283e0985b5e16a7d67e018a16b0d52f09b90c (diff)
chore(3p/sources): Bump channels & overlays r/4980
Upstream nixpkgs removed a lot of aliases this time, so we needed to do
the following transformations. It's a real shame that aliases only
really become discoverable easily when they are removed.

* runCommandNoCC -> runCommand
* gmailieer -> lieer
  We also need to work around the fact that home-manager hasn't catched
  on to this rename.
* mysql -> mariadb
* pkgconfig -> pkg-config
  This also affects our Nix fork which needs to be bumped.
* prometheus_client -> prometheus-client
* rxvt_unicode -> rxvt-unicode-unwrapped
* nix-review -> nixpkgs-review
* oauth2_proxy -> oauth2-proxy

Additionally, some Go-related builders decided to drop support for
passing the sha256 hash in directly, so we need to use the generic hash
arguments.

Change-Id: I84aaa225ef18962937f8616a9ff064822f0d5dc3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6792
Autosubmit: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Reviewed-by: flokli <flokli@flokli.de>
Reviewed-by: tazjin <tazjin@tvl.su>
Reviewed-by: wpcarro <wpcarro@gmail.com>
Diffstat (limited to 'users/grfn/terraform/workspace.nix')
-rw-r--r--users/grfn/terraform/workspace.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/users/grfn/terraform/workspace.nix b/users/grfn/terraform/workspace.nix
index 92bf6e4ec1..114105642a 100644
--- a/users/grfn/terraform/workspace.nix
+++ b/users/grfn/terraform/workspace.nix
@@ -3,7 +3,7 @@ name: { plugins }: module_tf:
 
 let
 
-  inherit (pkgs) lib runCommandNoCC writeText writeScript;
+  inherit (pkgs) lib runCommand writeText writeScript;
   inherit (lib) filterAttrsRecursive;
 
   allPlugins = (p: plugins p ++ (with p; [
@@ -38,7 +38,7 @@ let
     plugins = plugins_tf;
   };
 
-  module = runCommandNoCC "module" { } ''
+  module = runCommand "module" { } ''
     mkdir $out
     ${lib.concatStrings (lib.mapAttrsToList (k: config_tf:
       (let
@@ -72,7 +72,7 @@ let
   '';
 
   # TODO: import (-config)
-  tfcmds = runCommandNoCC "${name}-tfcmds" { } ''
+  tfcmds = runCommand "${name}-tfcmds" { } ''
     mkdir -p $out/bin
     ln -s ${init} $out/bin/init
     ln -s ${tfcmd} $out/bin/validate
@@ -95,7 +95,7 @@ in
   #   destroy = depot.nix.nixRunWrapper "destroy" tfcmds;
   # };
 
-  test = runCommandNoCC "${name}-test" { } ''
+  test = runCommand "${name}-test" { } ''
     set -e
     export TF_STATE_ROOT=$(pwd)
     ${tfcmds}/bin/init