about summary refs log tree commit diff
path: root/users/grfn/system/system/modules/development.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2022-05-31T19·34-0400
committerclbot <clbot@tvl.fyi>2022-05-31T19·38+0000
commit8851075c2764fecde2a112815d7958d5d29fb406 (patch)
tree3d145c5855117324d33382b6c9d75b8e5c606701 /users/grfn/system/system/modules/development.nix
parentfb228861656a7dff2d3619a7b4b70bce26152b23 (diff)
feat(grfn/system): Resuscitate roswell r/4195
Resuscitate the configuration for roswell, the semi-portable
configuration I use for ec2 development boxes. Lots of the changes here
are trying to get Tramp working.

Change-Id: I2dc2fd1d9aa76e145fa3f3f847af761cb652ab47
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5798
Reviewed-by: grfn <grfn@gws.fyi>
Autosubmit: grfn <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/grfn/system/system/modules/development.nix')
-rw-r--r--users/grfn/system/system/modules/development.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/users/grfn/system/system/modules/development.nix b/users/grfn/system/system/modules/development.nix
index bfa0e22cff..d17e9d424c 100644
--- a/users/grfn/system/system/modules/development.nix
+++ b/users/grfn/system/system/modules/development.nix
@@ -3,4 +3,13 @@
 {
   virtualisation.docker.enable = true;
   users.users.grfn.extraGroups = [ "docker" ];
+
+  security.pam.loginLimits = [
+    {
+      domain = "grfn";
+      type = "soft";
+      item = "nofile";
+      value = "65535";
+    }
+  ];
 }