about summary refs log tree commit diff
path: root/users/grfn/system/home/platforms/linux.nix
diff options
context:
space:
mode:
authorAspen Smith <grfn@gws.fyi>2024-02-12T03·00-0500
committerclbot <clbot@tvl.fyi>2024-02-14T19·37+0000
commit82ecd61f5c699cf3af6c4eadf47a1c52b1d696c6 (patch)
tree429c5e078528000591742ec3211bc768ae913a78 /users/grfn/system/home/platforms/linux.nix
parent0ba476a4266015f278f18d74094299de74a5a111 (diff)
chore(users): grfn -> aspen r/7511
Change-Id: I6c6847fac56f0a9a1a2209792e00a3aec5e672b9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10809
Autosubmit: aspen <root@gws.fyi>
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'users/grfn/system/home/platforms/linux.nix')
-rw-r--r--users/grfn/system/home/platforms/linux.nix90
1 files changed, 0 insertions, 90 deletions
diff --git a/users/grfn/system/home/platforms/linux.nix b/users/grfn/system/home/platforms/linux.nix
deleted file mode 100644
index 4e4e02b451b3..000000000000
--- a/users/grfn/system/home/platforms/linux.nix
+++ /dev/null
@@ -1,90 +0,0 @@
-{ config, pkgs, ... }:
-
-let
-
-  depot = config.lib.depot;
-
-in
-
-{
-  imports = [
-    ../modules/alacritty.nix
-    ../modules/alsi.nix
-    ../modules/development.nix
-    ../modules/emacs.nix
-    ../modules/email.nix
-    ../modules/firefox.nix
-    ../modules/games.nix
-    ../modules/shell.nix
-    ../modules/tarsnap.nix
-    ../modules/vim.nix
-  ];
-
-  xsession.enable = true;
-
-  home.packages = with pkgs; [
-    # Desktop stuff
-    arandr
-    firefox
-    feh
-    chromium
-    xclip
-    xorg.xev
-    picom
-    peek
-    signal-desktop
-    apvlv # pdf viewer
-    vlc
-    irssi
-    gnutls
-    pandoc
-    barrier
-    depot.tools.nsfv-setup
-    gimp # TODO(grfn): use glimpse once it build again
-
-    # System utilities
-    powertop
-    usbutils
-    pciutils
-    gdmap
-    lsof
-    tree
-    nmap
-    iftop
-
-    # Security
-    gnupg
-    keybase
-    openssl
-    yubikey-manager
-    # TODO(grfn): lagging behind yubikey-manager and doesn't support cryptography >= 39
-    # yubikey-manager-qt
-
-    # Spotify...etc
-    spotify
-    playerctl
-  ];
-
-  services.redshift = {
-    enable = true;
-    provider = "geoclue2";
-  };
-
-  services.pasystray.enable = true;
-
-  services.gpg-agent = {
-    enable = true;
-    # previous default has been removed from nixpkgs
-    pinentryFlavor = "qt";
-  };
-
-  programs.zsh.initExtra = ''
-    [[ ! $IN_NIX_SHELL && "$TERM" != "dumb" ]] && alsi -l
-  '';
-
-  services.lorri.enable = true;
-
-  services.dropbox = {
-    enable = true;
-  };
-}