about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/lib/cloneRepo.nix
diff options
context:
space:
mode:
authorAspen Smith <grfn@gws.fyi>2024-02-12T03·00-0500
committerclbot <clbot@tvl.fyi>2024-02-14T19·37+0000
commit82ecd61f5c699cf3af6c4eadf47a1c52b1d696c6 (patch)
tree429c5e078528000591742ec3211bc768ae913a78 /users/grfn/system/home/modules/lib/cloneRepo.nix
parent0ba476a4266015f278f18d74094299de74a5a111 (diff)
chore(users): grfn -> aspen r/7511
Change-Id: I6c6847fac56f0a9a1a2209792e00a3aec5e672b9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10809
Autosubmit: aspen <root@gws.fyi>
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'users/grfn/system/home/modules/lib/cloneRepo.nix')
-rw-r--r--users/grfn/system/home/modules/lib/cloneRepo.nix76
1 files changed, 0 insertions, 76 deletions
diff --git a/users/grfn/system/home/modules/lib/cloneRepo.nix b/users/grfn/system/home/modules/lib/cloneRepo.nix
deleted file mode 100644
index 806a8be03cb2..000000000000
--- a/users/grfn/system/home/modules/lib/cloneRepo.nix
+++ /dev/null
@@ -1,76 +0,0 @@
-{ lib, config, ... }:
-with lib;
-{
-  options = {
-    grfn.impure.clonedRepos = mkOption {
-      description = "Repositories to clone";
-      default = { };
-      type = with types; attrsOf (
-        let
-          sm = submodule {
-            options = {
-              url = mkOption {
-                type = nullOr str;
-                description = "URL of repository to clone";
-                default = null;
-              };
-
-              github = mkOption {
-                type = nullOr str;
-                description = "Github owner/repo of repository to clone";
-                default = null;
-              };
-
-              path = mkOption {
-                type = str;
-                description = "Path to clone to";
-              };
-
-              onClone = mkOption {
-                type = str;
-                description = ''
-                  Shell command to run after cloning the repo for the first time.
-                  Runs inside the repo itself.
-                '';
-                default = "";
-              };
-
-              after = mkOption {
-                type = listOf str;
-                description = "Activation hooks that this repository must be cloned after";
-                default = [ ];
-              };
-            };
-          };
-        in
-        addCheck sm (cr: (! isNull cr.url || ! isNull cr.github))
-      );
-    };
-  };
-
-  config = {
-    home.activation =
-      mapAttrs
-        (_: { url
-            , path
-            , github
-            , onClone
-            , after
-            , ...
-            }:
-          let repoURL = if isNull url then "git@github.com:${github}" else url;
-          in hm.dag.entryAfter ([ "writeBoundary" ] ++ after) ''
-            $DRY_RUN_CMD mkdir -p $(dirname "${path}")
-            if [[ ! -d ${path} ]]; then
-              if $DRY_RUN_CMD git clone "${repoURL}" "${path}"; then
-                pushd ${path}
-                $DRY_RUN_CMD ${onClone}
-                popd
-              else
-                echo "Git repository ${path} failed to clone"
-              fi
-            fi
-          '')
-        config.grfn.impure.clonedRepos;
-  };
-}