about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/i3.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2021-11-08T01·45-0500
committergrfn <grfn@gws.fyi>2021-11-08T03·31+0000
commitbb980158a785b0ce23d25fa0f74c996311df7a67 (patch)
tree9d1e03058de9a19edd720be216fd6d997557338b /users/grfn/system/home/modules/i3.nix
parent56718d14b157a18a6a907d8546ee0c0bab96be30 (diff)
fix(gs/home): Move dunst shortcuts into i3 config r/3024
Dunst as of 1.7.0 apparently no longer supports keyboard shortcuts (so
much for semantic versioning) in favor of having them be bound in the
window manager to invocations of `dunstctl`.

Change-Id: Ic3f10a29061c19ea0002e0f6d596baeafa58d968
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3815
Reviewed-by: grfn <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--users/grfn/system/home/modules/i3.nix11
1 files changed, 4 insertions, 7 deletions
diff --git a/users/grfn/system/home/modules/i3.nix b/users/grfn/system/home/modules/i3.nix
index c56c9d556b..df0859b46a 100644
--- a/users/grfn/system/home/modules/i3.nix
+++ b/users/grfn/system/home/modules/i3.nix
@@ -166,6 +166,10 @@ in {
               # Notifications
               "${mod}+Shift+n" = "exec killall -SIGUSR1 .dunst-wrapped";
               "${mod}+n" = "exec killall -SIGUSR2 .dunst-wrapped";
+              "Control+space" = "exec ${pkgs.dunst}/bin/dunstctl close";
+              "Control+Shift+space" = "exec ${pkgs.dunst}/bin/dunstctl close-all";
+              "Control+grave" = "exec ${pkgs.dunst}/bin/dunstctl history-pop";
+              "Control+Shift+period" = "exec ${pkgs.dunst}/bin/dunstctl action";
             })]);
 
           fonts = [ decorationFont ];
@@ -333,13 +337,6 @@ in {
             color = "#aaaaaa";
           };
 
-          shortcuts = {
-            close = "ctrl+space";
-            close_all = "ctrl+shift+space";
-            history = "ctrl+grave";
-            context = "ctrl+shift+period";
-          };
-
           urgency_low = {
             background = base03;
             foreground = base3;